"Something went wrong" on Prospects page
Incident Report for Reply
Resolved
Issues with People page have been successfully resolved
Posted Sep 24, 2021 - 06:58 UTC
Identified
Some customers are experiencing issues with Prospects page today where some actions results in the error - "Something went wrong". The issue has been identified and the fix will be released tomorrow morning in EEST time zone.

We apologise for the inconvenience this might cause you
Posted Sep 23, 2021 - 17:56 UTC
This incident affected: Reply Web Application.